Flutter プロジェクト作成時にエラー

環境:Flutter Channel dev, 1.22.0-1.0.pre, on Mac OS X 10.15.5

まずはエラーの内容は以下の通りです。これが無限ループします。。

Building flutter tool...
The current Dart SDK version is 2.10.0-4.0.dev.flutter-20bf2fcf56.

Because flutter_tools depends on collection >=1.15.0-nnbd <1.15.0-nullsafety.2 which requires SDK version >=2.9.0-18.0 <=2.9.10, version solving failed.
Error: Unable to 'pub upgrade' flutter tool. Retrying in five seconds... (9 tries left)

エラーの対応方法は以下です。

1、flutter SDKのディレクトリに移動します。 (flutter/bin)

2、rm -r cache    を実行

3、git pull origin –ff-only  を実行

4、flutter doctorを実行

備忘録としてメモ書きしました。参考までに